GNU Go for S60



GNUGoS60 is a port of the FSF's GNU Go game engine to Nokia's S60 smartphone platform running on SymbianOS.

It is Free Software.

Saturday, May 08, 2010

Bye CVS, Hello SVN

I have switched over the source control for gnugos60 on sourceforge from CVS to Subversion now. Here's the instructions for anyone that cares. This should hopefully make it a bit easier for me to to actually make some changes to the code.

The 0.2 version where any new features are doesn't compile at the moment, so I think I'll just go ahead and release a 0.1.2 that only contains the memory usage / speedup fix and an up to date certificate so it can actually be installed.

Tune in next week. Same bat time. Same bat channel.

Or not, as the case may be.

Saturday, March 01, 2008

Certificate Expired Problems

Someone reported a problem that when installing getting a "Certificate Expired" message. I thnk this is because it's one year since I did the self signing on the SIS, and self signing lasts only one year.

I'll upload a re-signed version later, but in the meantime anybody who experiences might try just setting the clock back a few months, and see if the install can succeed. You can reset the clock back to the correct date after install.

Tuesday, December 04, 2007

GNUGoS60 v0.1.1 is released

GNUGoS60 v0.1.1 is released for S60 2nd FP2 phones.

It fixes only this FP2 specific error, quite possibly only partially:
I have reduced the cache size from 2MB to 400k, and this seems to allow it to do some moves. I was able to make 10 or so on the 6680 RDA before I got fed up waiting for it :)

Please let me know if the out of memory still persists on any FP2 phones, and after approximately how many moves.

Note: For other S60 2nd users with low memory phones, (like 7610 or 6600) this may be worth a try also if you are experiencing this bug, but I haven't tried this release on anything other than 6680, and it was built with the FP2 SDK:

Monday, December 03, 2007

GNUGoS60 v0.1 for S60 2nd FP2 released

I just uploaded a v0.1 package for S60 2nd FP2 phones now.

I found that the reason it didn't work on them before was because there is a bug in the firmware for all phones based on that release that means ECompXL doesn't work at all. Staffan Ulfberg (of EEMame) had wrote in a forum about a similar problem, and mentioned he had a workaround, so I emailed him for the solution, and he kindly responded with help.

It now launches on 6680, but honestly I think anybody installing it is going to be disappointed, because you get out of memory so easily. Even after 1 move or something. I have read that 6630, 6680 and 6681 have even lower memory than 2.0 or FP1 devices like 6600 or 7610, which get out of memory too, but after 10-20 moves.

Anyway, the game is basically unplayable on those devices I would say.